Отмена выполнения задачи исполнителя и вложенных бизнес-процессов

Публикация № 1180278

Управление - Управление бизнес-процессами (BPM)

Бизнес-процессы Задача исполнителя

После реализации проекта, основанного на бизнес-процессах - потребовался некий инструмент для администрирования задач исполнителя. Для отмены ошибочно выполненных задач и для отмены ошибочных переходов во вложенные бизнес-процессы.

Скажу сразу, ранее практически не попадалось задач по бизнес-процессам. А тут пришлось с нуля в также не знакомой мне области создавать подсистему "Претензионно-исковая деятельность". 

Проект сдан, теперь началась работа пользователей и появилась потребность администрирования их работы. Всё, что находилось в 1С блогосфере - было по созданию бизнес-процессов и ничего не нашлось толкового по отмене задачи ошибочной и тем более по отмене ошибочного перехода в вложенный БП (бизнес-процесс далее).

Конечно, прилагаемая обработка не взлетит у Вас! У меня свои названия БП и Задача исполнителя так же не стандартно названа. Но для понимания принципа, как образец к действию сгодится для начинающих (а опытные могут дать свои замечания и критику).

Шапка наполнена реквизитами под учет моих карт и моих БП. У меня 11 БП, которые могут стартовать в одном из двух  БП, дальше вызовом вложенных сливаются в один маршрут и по цепочке маршрута могут циклически вызываться из одного в другой и снова возвращаться в середину. 

Судебное ведение дела уходит то в Апелляцию, может в Кассацию. Из них вызывается Сопровождение в суде, мировое соглашение или на Исполнительное производство. Очень запутанные схемы и пользователи естественно будут ошибаться и не то выбирать при выполнении очередной задачи.

По схемам у меня раздвоение более чем на две ветки не случается и поэтому в шапку забил поля под две ветки. Сначала потерял время над попыткой автоматизации заполнения задачами шапки при выборе документа Претензия, это у меня ведущий документ - из которого централизованно ведется весь ход и управление маршрутом\задачами. Но автоматизации не вышло, это нужно было предусмотреть на стадии проектирования. А я когда проектировал предусмотрел это мне казалось, но только для линейных схем. В задаче у меня был предусмотрен реквизит - Следующая задача и он заполнялся при создании следующей задачи. Но после разделения на две ветки, одна задача созданная из двух уже теряется в этой цепочке.

Тогда принял решение не терять время, на будущее решил, нужно будет создать регистр сведений для записи последовательности задач исполнителя, но это на будущее. А сейчас сделал просто вывод сразу всех полей без управления их видимостью в зависимости от ситуации на маршруте и пользователю выводится карта текущая с отметками выполненных и ожидающих выполнения задач. Пользователь уже сам, проанализировав карту, решает, какую задачу следует удалить и отменить выполнение предыдущей - они выведены в шапку всегда. Напомню, поля заполняются автоматически при выборе документа Претензия.

Так же при переходе в вложенный БП, если это первый шаг нового БП и он ожидает выполнения, то поле с выполненной задачей 1 будет заполнено последней выполненной задачей из БП вызвавшего это вложенный БП. Поле Предыдущий БП заполнится исходным БП. Отменить в этот момент можно текущий БП, при этом автоматом отметятся к удалению задача которая ожидает выполнения в вложенном БП, отменится выполнение предыдущей задачи из вызвавшего БП, удалится ведущая задача, которую автоматически создал БП при создании вложенного и в моем случае ещё свои мелкие необходимости, как например перезапись реквизита Текущий БП у документа Претензия.

Так же замечу, у меня при удалении задачи исполнителя дополнительно производятся нужные в моём частном случае действия, как например установка дополнительных свойств у объекта, для отмены проверки установки пометки удаления на задачу. Это у меня программно запрещено пользователю! Иначе там сразу начался ужас в данных. Но это все сопутствующая лирика.

Так же в правой части шапки добавил возможность руками выбрать из списка точек, нужную точку маршрута и автоматом подтягивается к ней предыдущая точка. Это понадобилось для случая, когда раздвоение маршрута одной веткой упёрлось в точку слияния и этот шаг у нас становится выполненным, но что бы его отменить - придется его отдельно выбрать руками. Автоматом его не определить так просто. Там же, справа, расположена командная кнопка "Отмена выбранной задачи" и под кнопкой пояснение боле менее подробное. Логика работы кнопки зависит от состояния задачи в поле Ручной выбор задачи. Если она выполнена, то предыдущая тоже выполнена и первое нажатие кнопки отменит выполнение выбранной задачи. Карта при этом обновит состояние, она вообще обновляется при основных действиях и есть кнопка обновления карты и заодно кнопка для левого поля шапки обновить задачи. Так вот, вернемся к нашей кнопке в правом поле. Второе нажатие уже удалит отмененную с выполнения первым нажатием задачу и отменит выполнение у предыдущей. Третий раз нажимать не надо, проверок на все случаи не вставлял)))

Спасибо awk, принял замечание по установке транзакции и заодно ещё скорректировал некоторые моменты, в частности получение ведущей задачи у удаляемого БП. Вот скорректированный код основных процедур, кто-то успел скачать уже обработку без исправления к сожалению, а там действительно транзакции не правильно в корне установлены были.

Процедура удаления не выполненного шага и отмены выполнения предыдущего или удаления входа в вложенный БП:

 


 

&НаСервере
Процедура ОтменаВложенногоБПНаСервере()
	
	Запрос = Новый Запрос;   //При удалении БП на всякий случай удалим все имеющиеся по нему задачи
	//на случай если по циклам маршрут вернулся к первому шагу и есть несколько задач уже выполненных
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	пирЗадачаИсполнителя.Ссылка КАК Ссылка
	|ИЗ
	|	Задача.пирЗадачаИсполнителя КАК пирЗадачаИсполнителя
	|ГДЕ
	|	пирЗадачаИсполнителя.БизнесПроцесс = &БизнесПроцесс";
	
	Запрос.УстановитьПараметр("БизнесПроцесс", ТекущийБП);
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		УдаляемаяЗадача = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
		УдаляемаяЗадача.ПометкаУдаления = Истина;
		УдаляемаяЗадача.ТочкаМаршрута 	= Неопределено;
		УдаляемаяЗадача.Претензия 		= Неопределено;
		УдаляемаяЗадача.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
		УдаляемаяЗадача.Записать();
	КонецЦикла;
	ОтменяемаяЗадача = ПредыдущаяЗадача1.ПолучитьОбъект();
	ОтменяемаяЗадача.Выполнена 			= Ложь;
	ОтменяемаяЗадача.СледующаяЗадача 	= Неопределено;
	ОтменяемаяЗадача.ДатаИсполнения 	= Дата(1,1,1,0,0,0);
	ОтменяемаяЗадача.Записать();
	
	УдаляемаяВедущаяЗадачаТекБП = ТекущийБП.ВедущаяЗадача.ПолучитьОбъект();
	УдаляемаяВедущаяЗадачаТекБП.ПометкаУдаления = Истина;
	УдаляемаяВедущаяЗадачаТекБП.ТочкаМаршрута 	= Неопределено;
	УдаляемаяВедущаяЗадачаТекБП.Претензия 		= Неопределено;
	УдаляемаяВедущаяЗадачаТекБП.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
	УдаляемаяВедущаяЗадачаТекБП.Записать();
	
	УдаляемыйБП = ТекущийБП.ПолучитьОбъект();
	УдаляемыйБП.ВедущаяЗадача 	= Неопределено;
	УдаляемыйБП.Стартован 		= Истина;
	УдаляемыйБП.Завершен 		= Истина;
	УдаляемыйБП.Записать();	
	ТекПретензия = Претензия.ПолучитьОбъект();
	ТекПретензия.ТекущийБП = ПредыдущийБП;
	ТекПретензия.Записать(РежимЗаписиДокумента.Проведение);
	
КонецПроцедуры
&НаСервере
Процедура ШагНазадНаСервере()
	
	Если УдалитьЗадачу1 И ЗначениеЗаполнено(ПоследняяЗадача1) Тогда
		УдаляемаяЗадача = ПоследняяЗадача1.ПолучитьОбъект();
		УдаляемаяЗадача.ПометкаУдаления = Истина;
		УдаляемаяЗадача.ТочкаМаршрута 	= Неопределено;
		УдаляемаяЗадача.Претензия 		= Неопределено;
		УдаляемаяЗадача.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
		УдаляемаяЗадача.Записать();
	КонецЕсли;
	Если УдалитьЗадачу2 И ЗначениеЗаполнено(ПоследняяЗадача2) Тогда
		УдаляемаяЗадача = ПоследняяЗадача2.ПолучитьОбъект();
		УдаляемаяЗадача.ПометкаУдаления = Истина;
		УдаляемаяЗадача.ТочкаМаршрута 	= Неопределено;
		УдаляемаяЗадача.Претензия 		= Неопределено;
		УдаляемаяЗадача.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
		УдаляемаяЗадача.Записать();
	КонецЕсли;
	
	Если ОтменитьЗадачу1 И ЗначениеЗаполнено(ПредыдущаяЗадача1) Тогда
		ОтменяемаяЗадача = ПредыдущаяЗадача1.ПолучитьОбъект();
		ОтменяемаяЗадача.Выполнена 			= Ложь;
		ОтменяемаяЗадача.СледующаяЗадача 	= Неопределено;
		ОтменяемаяЗадача.ДатаИсполнения 	= Дата(1,1,1,0,0,0);
		ОтменяемаяЗадача.Записать();
	КонецЕсли;
	
	Если ОтменитьЗадачу2 И ЗначениеЗаполнено(ПредыдущаяЗадача2) Тогда
		ОтменяемаяЗадача = ПредыдущаяЗадача2.ПолучитьОбъект();
		ОтменяемаяЗадача.Выполнена 			= Ложь;
		ОтменяемаяЗадача.СледующаяЗадача 	= Неопределено;
		ОтменяемаяЗадача.ДатаИсполнения 	= Дата(1,1,1,0,0,0);
		ОтменяемаяЗадача.Записать();
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Процедура ШагНазадНаСервере_()
	
	НачатьТранзакцию();
	Попытка
		Если ОтменитьБП Тогда
			ОтменаВложенногоБПНаСервере();
		Иначе
			ШагНазадНаСервере();
		КонецЕсли;
		ЗафиксироватьТранзакцию();
	Исключение
		ОтменитьТранзакцию();
		ТекстСообщенияОбОшибке = КраткоеПредставлениеОшибки(ИнформацияОбОшибке());
		ВызватьИсключение ТекстСообщенияОбОшибке ; // Запись в ЖР и т.п.
	КонецПопытки;
	
	ПретензияПриИзмененииНаСервере();
	Если ЗначениеЗаполнено(ТекущийБП) Тогда
		ПолучитьКартуНаСервере();
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура ШагНазад(Команда)
	ШагНазадНаСервере_();
КонецПроцедуры

 

 

Разрабатываемая мной подсистема ПИР, для которой написал обработку, интегрирована в Управление холдингом 1.3

Версия платформы 1С:Предприятие 8.3 (8.3.13.1644)

Скачать файлы

Наименование Файл Версия Размер
Отмена выполнения задачи исполнителя и вложенных бизнес-процессов:
.epf 10,17Kb
15.01.20
1
.epf 1.2 10,17Kb 1 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. awk 695 16.01.20 09:24 Сейчас в теме
Нарушение стандарта 1С в коде, например "Работа с транзакциями"

1.3. При использовании транзакций необходимо предусмотреть обработку исключений, придерживаясь следующих правил:

* метод НачатьТранзакцию должен быть за пределами блока Попытка-Исключение непосредственно перед оператором Попытка;
2. dadel 9 16.01.20 10:15 Сейчас в теме
(1) Согласно 1.3 да, там рекомендуется непосредственно перед попыткой.
Но если у меня идет получение объектов из выборки в цикле и хоть в одной из нескольких записей если ошибка, то нужно отменить все изменения. Как тут согласно рекомендации п1.3 реализовать?
А вообще код не оптимизировал конечно, выложил просто как некий план к действию, направление в котором нужно копать. Мой частный случай вряд ли кому то подойдет, сами объекты не совпадут.
Но если поясните подробнее, как в моём случае правильнее прописать Транзакцию - буду благодарен!)
3. awk 695 16.01.20 13:16 Сейчас в теме
(2) Да легко.

Как пример:

&НаСервере
Процедура ОтменаВложенногоБПНаСервере_БезТранзакции()
    
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    пирЗадачаИсполнителя.Ссылка КАК Ссылка
    |ИЗ
    |    Задача.пирЗадачаИсполнителя КАК пирЗадачаИсполнителя
    |ГДЕ
    |    пирЗадачаИсполнителя.БизнесПроцесс = &БизнесПроцесс";
    
    Запрос.УстановитьПараметр("БизнесПроцесс", ТекущийБП);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        УдаляемаяЗадача = ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
        УдаляемаяЗадача.ПометкаУдаления = Истина;
        УдаляемаяЗадача.ТочкаМаршрута     = Неопределено;
        УдаляемаяЗадача.Претензия         = Неопределено;
        УдаляемаяЗадача.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
        УдаляемаяЗадача.Записать();
    КонецЦикла;
    ОтменяемаяЗадача = ПредыдущаяЗадача1.ПолучитьОбъект();
    ОтменяемаяЗадача.Выполнена             = Ложь;
    ОтменяемаяЗадача.СледующаяЗадача     = Неопределено;
    ОтменяемаяЗадача.ДатаИсполнения     = Дата(1,1,1,0,0,0);
    ОтменяемаяЗадача.Записать();
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    пирЗадачаИсполнителя.Ссылка КАК Ссылка
        |ИЗ
        |    Задача.пирЗадачаИсполнителя КАК пирЗадачаИсполнителя
        |ГДЕ
        |    пирЗадачаИсполнителя.БизнесПроцесс = &БизнесПроцесс
        |    И пирЗадачаИсполнителя.Дата >= &Дата
        |    И пирЗадачаИсполнителя.ЗадачаПредмет = НЕОПРЕДЕЛЕНО
        |    И НЕ пирЗадачаИсполнителя.Выполнена";
    
    Запрос.УстановитьПараметр("БизнесПроцесс", ПредыдущийБП);
    Запрос.УстановитьПараметр("Дата", ПредыдущаяЗадача1.Дата);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    Выборка = РезультатЗапроса.Выбрать();
    
    Пока Выборка.Следующий() Цикл
        УдаляемаяЗадача = Выборка.Ссылка.ПолучитьОбъект();    //Ведущая задача для удаления
        УдаляемаяЗадача.ПометкаУдаления = Истина;
        УдаляемаяЗадача.ТочкаМаршрута     = Неопределено;
        УдаляемаяЗадача.Претензия         = Неопределено;
        УдаляемаяЗадача.ДополнительныеСвойства.Вставить("ОтменаВыполнения",Истина);
        УдаляемаяЗадача.Записать();

    КонецЦикла;

    УдаляемыйБП = ТекущийБП.ПолучитьОбъект();
    УдаляемыйБП.ВедущаяЗадача     = Неопределено;
    УдаляемыйБП.Стартован         = Истина;
    УдаляемыйБП.Завершен         = Истина;
    УдаляемыйБП.Записать();    
    ТекПретензия = Претензия.ПолучитьОбъект();
    ТекПретензия.ТекущийБП = ПредыдущийБП;
    ТекПретензия.Записать(РежимЗаписиДокумента.Проведение);
    
    
КонецПроцедуры

&НаСервере
Процедура ОтменаВложенногоБПНаСервере()
    
    НачатьТранзакцию();
    
    Попытка
        ОтменаВложенногоБПНаСервере_БезТранзакции()
        ЗафиксироватьТранзакцию(); 
    Исключение
        ОтменитьТранзакцию();
	ТекстСообщенияОбОшибке = КраткоеПредставлениеОшибки(ИнформацияОбОшибке());
        ВызватьИсключение ТекстСообщенияОбОшибке ; // Запись в ЖР и т.п.
    КонецПопытки;
        
КонецПроцедуры
Показать
4. dadel 9 16.01.20 16:40 Сейчас в теме
(3)
Попытка
ОтменаВложенногоБПНаСервере_БезТранзакции()
ЗафиксироватьТранзакцию();
Исключение
ОтменитьТранзакцию();
ТекстСообщенияОбОшибке = КраткоеПредставлениеОшибки(ИнформацияОбОшибке());
ВызватьИсключение ТекстСообщенияОбОшибке ; // Запись в ЖР и т.п.
КонецПопытки;

Здорово!)
И главное просто), приму к сведению.
9. dadel 9 17.01.20 10:31 Сейчас в теме
(3)Исправил обработку и текст по замечанию.
Спасибо!
Жаль кто-то скачал сегодня утром без исправлений (хотя я думал кода достаточно будет и не думал, что будут скачивать). А там действительно транзакция может при ошибке в середине отмениться и дальше будет работать обработка уже не в транзакции и получится не хорошо...
5. CyberCerber 344 16.01.20 20:19 Сейчас в теме
Где-то лет семь назад делал возможность возврата к произвольной точке маршрута. Можно было открыть схему, правой кнопкой нажать на блок и выбрать в меню. А потом еще извратился сделать переход наоборот вперед, т.е. вообще к любой точке.
Вообще механизм БП в 1С хороший, но жаль не популярный и поэтому мало развиваемый.
6. dadel 9 17.01.20 00:04 Сейчас в теме
(5)Ну просто перепрыгнуть в любую точку текущего БП можно просто изменив в задаче точку маршрута.
Я так делал для отладки, сразу перепрыгивал весь БП на точку перехода в вложенный БП. У меня схем(карт) куча и все они друг с другом связаны, по факту это один БП раздробленный. И попасть например в процесс Исполнения Судебного решения нужно только пройдя через Переговорную работу, Претензионную, Подготовку к Судебному процессу и т.д.
Перепрыгивать можно но говорить о сохранении целостности маршрута тут не приходится, я только в отладке так прыгал. А у меня задача как можно адекватнее откатить\отменить неправильные шаги.
Сначала в опытной эксплуатации у меня пользователям поле точка БП было открыто, так шаловливые именно так и стали прыгать))) Сразу увидел бардак и закрыл.
7. CyberCerber 344 17.01.20 00:09 Сейчас в теме
(6) Ну нет, через изменение точки маршрута в задаче не делал, это как-то слишком грубо. Происходило именно восстановление актуальности нужной задачи и отмена всех после нее.
А переход вперед был сделан уже для эксперимента, конечно, фактического смысла в нем было немного.
8. dadel 9 17.01.20 00:28 Сейчас в теме
(7)Я просто понял фразу "ткнуть в произвольную точку маршрута" именно так. Что можно из текущей перепрыгнуть в любую точку, пропустив все промежуточные например.
Оставьте свое сообщение

См. также

Анализ выполнения бизнес-процессов

Отчеты и формы Пользователь Внешний отчет (ert,erf) v8 ERP2 УТ11 УУ Абонемент ($m) Управление бизнес-процессами (BPM)

Отчет позволяет посмотреть текущее состояние всех БП,  а также время выполнения на каждом этапе бизнес-процесса. Это дает возможность проанализировать узкие места в Вашем бизнесе, принять меры, если задержки на каком-либо этапе стали неоправданно расти.

2 стартмани

24.12.2019    812    milkers    0       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Загрузка из ППР (Передовые платежные решения) - Сведения о заправках на АЗС за сутки из сервиса ППР

Инструменты и обработки Пользователь Внешняя обработка (ert,epf) v8 ERP2 БП3.0 1С:CRM Транспорт, автопарки, такси Россия БУ УУ Абонемент ($m) Учет ТМЦ Управление бизнес-процессами (BPM) Управленческий учет (прочее) Внешние источники данных

Обработка «Загрузка заправок на АЗС из ППР» реализует механизм подключения через API к сервису агрегатора топливных карт Передовые Платежные Решения. Позволяет получить данные по всем заправкам автотранспорта за указанные сутки.

1 стартмани

17.11.2019    1210    3    aaa_pol    0       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Центр компетенций 1С #1: Технологический блог

Статья Программист Бизнес-аналитик Руководитель проекта Архив с данными v8 Россия Абонемент ($m) Управление бизнес-процессами (BPM)

Привет! Меня зовут Андрей, я - директор по развитию 1С в международной переводческой компании. Представляете, наша ERP на платформе 1С работает в наших офисах по всему миру: Австрия, Великобритания, Германия, Чехия, Украина, Аргентина, США, Китай, Казахстан и конечно Россия. Директором по развитию я стал недавно и в связи с повышением по работе стал задаваться вопросами создания в компании центра компетенций 1С, где бы аккумулировались накопленные знания, кейсы, прецеденты и лучшие практики. Второй интересующий меня момент - развитие в группе разработки 1С принципа меритократии идей. Что означает поощрение и развитие компетентности и инициативы сотрудников для делегирования им большей ответственности. В перспективе это имеет большее качество, нежели авторитарное принятие решения руководителем. В мини-блоге на Инфостарте я буду делиться своими исследованиями по данной теме и буду рад их обсуждению.

1 стартмани

01.07.2019    3276    chuprina_as    0       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Автоматическая генерация технологических карт на основе графической схемы

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Практика программирования Разработка Управление бизнес-процессами (BPM)

В статье описывается способ генерация технологических карт на основе заданного графической схемой техпроцесса. Рассматриваются вопросы программного взаимодействия с объектом "графическая схема" и приведен механизм обхода графической схемы для получения карты техпроцесса. Тестировалось на платформе 8.3.12.

1 стартмани

27.03.2019    2850    all_net    0       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Программное управление бизнес-процессом "Заявка на Страхование" в 1С: Документооборот из внешней системы на практическом примере

Инструменты и обработки no Внешняя обработка (ert,epf) v8 ДО Windows Документооборот и делопроизводство Абонемент ($m) Управление бизнес-процессами (BPM)

В статье демонстрируется возможный пример реализации бизнес-процесса в ДО на примере практической задачи. Материал может быть полезен тем, кому быстро надо разобраться в архитектуре комплексных БП Документооборот.

1 стартмани

31.01.2019    4037    5    alexander-lubich    2       

Подсистема Бизнес-процессы. Создание бизнес-процессов в пользовательском режиме (управляемые формы)

Инструменты и обработки Программист Пользователь Конфигурация (md, cf) v8::УФ v8::Бизнес-процессы 1cv8.cf УУ Windows Абонемент ($m) Управление бизнес-процессами (BPM)

Подсистема бизнес-процессы позволяет расширить конфигурации в которых не используются бизнес-процессы. Бизнес-процессы создаются в пользовательском режиме различной сложности по усмотрению пользователя. Простой и понятный механизм создания бизнес-процессов.

1 стартмани

02.01.2019    5414    41    lesv    16       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Управление задачами в 1С - готовая подсистема с открытым кодом и широким базовым функционалом. Версия 1.0.6

Инструменты и обработки no Архив с данными v8 Абонемент ($m) Инструментарий разработчика Управление бизнес-процессами (BPM) Управление проектом

Конфигурация-подсистема для управления задачами с базовым функционалом, который, однако, может удовлетворить довольно широкий спектр запросов. Есть статусы и приоритеты, учёт трудозатрат по исполнителям и даже базовые разграничения по правам. А открытый исходный код позволит на базе данной конфигурации развить систему до любого уровня сложности.

2 стартмани

17.12.2018    13453    92    for_sale    38       

Применение цифровой подписи при организации учёта ТМЦ и ГСМ

Статья Программист Архив с данными v8::Mobile v8::Бизнес-процессы 1cv8.cf Абонемент ($m) Защита и шифрование Управление бизнес-процессами (BPM) Мобильная разработка

Статья о том, как внедрение мобильного приложения в бизнес-процессы компании сократило оборот бумажных документов, а простая электронная подпись - заменила аналоговую.

1 стартмани

25.10.2018    5381    2    ikekoval    2       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Шаблон бизнес-модели Остервальдера и Пинье

Отчеты и формы Бизнес-аналитик Конфигурация (md, cf) v8 Абонемент ($m) Управление бизнес-процессами (BPM)

Конфигурация с документом "Шаблон" и печатной формой шаблона бизнес-модели Остервальдера и Пинье.

1 стартмани

23.09.2018    4788    3    SergeySm    0       

"Простые регламенты" - помощник создания правильных регламентов ваших бизнес-процессов !БЕСПЛАТНО!

Отчеты и формы Бизнес-аналитик Пользователь Руководитель проекта Конфигурация (md, cf) v8::Бизнес-процессы 1cv8.cf УУ Абонемент ($m) Управление бизнес-процессами (BPM)

В статье - презентация нового БЕСПЛАТНОГО продукта для регламентации ваших бизнес-процессов. С нашей методикой ваши регламенты будут работать!

1 стартмани

06.09.2018    11928    23    siddy    0       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Система по управлению задачами в 1С: УТ 11

Инструменты и обработки Пользователь Руководитель проекта Расширение (cfe) v8 v8::Бизнес-процессы УТ11 УУ Абонемент ($m) Обработка документов Обработка справочников Управление бизнес-процессами (BPM)

В 1С: УТ 11 есть очень удобный механизм - задания. Можно создавать задание любому пользователю на основании справочника или документа. Например: "Исправить отчет о розничных продажах". Но можно прикреплять только один объект к задаче. А если необходимо обработать целый список документов? Данное расширение конфигурации позволяет прикреплять к задаче сразу несколько объектов. Благодаря этому механизму можно даже организовать передачу вопросов и обращений от пользователей к ИТ-службе.

2 стартмани

12.05.2018    10766    24    Kutuzov    3       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Бизнес-процессы: Согласование скидки с клиентом

Отчеты и формы Программист Бизнес-аналитик Пользователь Руководитель проекта Архив с данными v8 1cv8.cf Оптовая торговля, дистрибуция, логистика УУ Оптовая торговля Ценообразование, анализ цен Абонемент ($m) Управление бизнес-процессами (BPM)

Пример бизнес-процесса согласования скидок клиентов. В статье шаблон типового процесса, схему которого можно скачать и адаптировать под свои нужны. Во вложение добавлена "рыба" регламента.

1 стартмани

04.12.2017    11319    7    siddy    0       

Бизнес-процессы: Процесс заключения договора с клиентом

Статья Программист Руководитель проекта Архив с данными v8 1cv8.cf УУ Управление взаимоотношениями с клиентами (СRM) Абонемент ($m) Управление бизнес-процессами (BPM)

Статья о том, как построить процесс работы с договорами клиентов. Написана по мотивам наших автоматизаций - постарались обобщить знания в шаблонный процесс, который легко подправить под свои нужды. К публикации прикреплен пример регламента такого процесса.

1 стартмани

30.11.2017    17327    13    siddy    0       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Условия для дополнительных реквизитов в задачах бизнес-процессов (шаблоны) + доработка интерфейса многостраничные реквизиты - расширение

Инструменты и обработки no Расширение (cfe) v8 ДО Документооборот и делопроизводство Абонемент ($m) Работа с интерфейсом Управление бизнес-процессами (BPM)

Существует проблема, когда добавляешь дополнительные реквизиты в шаблоны бизнес-процессов, нет отбора по шаблону. То есть когда мы на определённый шаблон, скажем - заявка на ремонт, хотим добавить реквизит - помещение, то это реквизит начинает отображаться во всех процессах. Что очень неудобно. Зачем реквизит помещение в процессе, скажем, создания договора? Расширение позволяет делать условие на шаблон и на папку шаблонов (без иерархии!!!) Плюс увеличивает размер многострочных реквизитов - в высоту *2 и в ширину 600.

4 стартмани

14.11.2017    8874    5    Vladimir45    14       

Автозадачи

Инструменты и обработки Программист Конфигурация (md, cf) v8::СКД Россия Абонемент ($m) Управление бизнес-процессами (BPM) Универсальные функции

Универсальный механизм управления потоками задач в информационной базе 1С. Самый востребованный инструмент из "кастомизации на лету".

1 стартмани

01.08.2017    26436    178    1c-intelligence    39       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации

Инструменты и обработки Пользователь Руководитель проекта Архив с данными v8 1cv8.cf БП3.0 КА2 УУ Документооборот и делопроизводство Абонемент ($m) Управление бизнес-процессами (BPM) Обработка документов Обработка справочников

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    42469    240    BlizD    194       

Работа с задачами исполнителя

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Управление бизнес-процессами (BPM)

Выполнение или отмена выполнения любой задачи бизнес-процесса

1 стартмани

05.05.2016    13261    10    di0xa    2       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Торговля глазами ветврача. Оформление ветеринарно-сопроводительных документов в системе Меркурий (Часть 3)

Статья Бизнес-аналитик Бухгалтер Пользователь Архив с данными v8 Сельское хозяйство и рыболовство Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Пищевая промышленность Беларусь Россия Казахстан УУ Windows Учет ТМЦ Абонемент ($m) Управление бизнес-процессами (BPM) Управленческий учет (прочее)

Для торговой компании объясняется, как выполнять типовые операции в системе Меркурий. Зачем нужен Меркурий? C его помощью можно оформлять ветсвидетельства бесплатно. Уточните у руководства, сколько денег платите ветеринарам. Например, сеть Перекресток платит 400 млн. руб. в год.

5 стартмани

22.01.2016    50107    10    axxell    5       

Производство глазами ветврача. Оформление ветеринарно-сопроводительных документов в системе Меркурий (Часть 2)

Статья Программист Бухгалтер Архив с данными v7.7 v8 1С7:Комплекс УПП1 1С7:ПУБ Сельское хозяйство и рыболовство Пищевая промышленность Беларусь Россия Казахстан УУ Производство готовой продукции (работ, услуг) Учет ТМЦ Абонемент ($m) Управление бизнес-процессами (BPM) Управленческий учет (прочее) Бухгалтерский учет

Для предприятия по производству пищевых продуктов объясняется, как выполнять типовые операции в системе Меркурий. Зачем нужен Меркурий? C его помощью можно оформлять ветсвидетельства бесплатно. Уточните у руководства, сколько денег платите ветеринарам. Например, сеть Перекресток платит 400 млн. руб. в год.

5 стартмани

19.01.2016    74969    10    axxell    9       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Бизнес-Процесс Для УПП УправлениеЗакупками

Отчеты и формы Бизнес-аналитик Бухгалтер Графическая схема (grs) v8 УПП1 Россия БУ УУ Windows Абонемент ($m) Управление бизнес-процессами (BPM)

Описание бизнес процесса в приложении в visio для блока управление закупками на 4х страницах с выходом в документы системы УПП ред 1.3. с проводками по документам

1 стартмани

24.05.2014    16139    39    BagiraN    1